Why is there a discrepancy?

Overview

This document covers discrepancies between publisher reporting platforms and Pub Maestro, in most cases the discrepancy is observed between a publisher's Ad Server and Pub Maestro.

The below sections documents requirements to investigate discrepancies as well as some common discrepancy causes we've observed and resolved.

Prerequisites

Discrepancies observed must be corroborated between your Sharethrough account manager and/or technical support.

Requirements Before Investigating

In order to ensure accurate reviews the following questions must be answered:

  1. Was the discrepancy within the last 90 days?
    • We are unable to review discrepancies older than 90 days.

  2. Are the site(s), domain(s), app(s), and/or relevant placement IDs still active?
    • Our review process requires us to ensure the ad configuration is working as expected, and there are no anomalies in the ad configuration.
  3. Is the discrepancy over the minimum threshold?
    • Web - 10% or more
    • Mobile - 15% or more
    • The above thresholds must be exceeded for a review to take place as there will generally be slight discrepancies between advertising systems due to the nature of, users habits, network conditions, implementation and configuration.

Reports

Before beginning any discrepancy reviews the following data and reports must be collected.

  • One report from the Sharethrough Pub Maestro platform
  • One report from the Publisher advertising platform or reporting system
  • Report time frames must match.
    • The more granular (month, week, day, hour) the better.
  • The timezone must match, and must be specified in the reports.
    • In smaller date ranges, such as a single day, it would be difficult to compare "apples to apples" unless the timezones are identical.
    • Pub Maestro generates reports in UTC, unless otherwise specified in the requested report.
  • Reports must include all relevant objects and dimensions.
    • We recommend including dimensions such as:
      • Order, Line Item, Placement (ID), Date
    • And Measures such as:
      • Ad Requests
      • Ad Responses (Code Served in AdManager)
      • Impressions (Ad Server Impressions in AdManager or similar)
      • Impressions (Viewable)
  • The data included in the publisher report must match up to your Pub Maestro account.
    • For example, Prebid line items for Sharethrough which explicitly target the Sharethrough key-value(s) must match to the domain or pKeys in the Pub Maestro platform.
    • In some cases we request access to your DFP to validate the configuration.

Notes

  • Our Pub Maestro platform "Rendered Impressions" should be within 10% of your Ad Server's "Ad Server Impressions" (in Ad Manager) or a similar metric in other ad servers. If you are not sure please reach out to support@sharethrough.com or your account manager.

Confirming the Data

A simple way to confirm a discrepancy is to start with a small data-set, such as a single day and comparing the same objects across platforms, if a discrepancy above the threshold is confirmed, the date-range may be expanded to confirm the discrepancy across multiple days.

Once the discrepancy is confirmed the culprit must be identified in order to resolve the issue, there are several possible causes for discrepancies. When common culprits are excluded please reach out to support@sharethrough.com for additional support.

Common Causes

  • Illegitimate Traffic

    • Symptoms
      • This is the most common cause of discrepancies between publisher systems and Pub Maestro reports.
        A publisher's reporting system may report ads have successfully served to this traffic, however, during our reconciliation process we have excluded the non-human/illegitimate traffic.
        This causes reporting to update and a discrepancy to appear.
    • How to Resolve
      • Implementing analytic and reporting systems (such as Google Analytics) will provide some information about session behavior, for example, if several users are coming from "Amazon" or "Microsoft Corp" with session times under 2 seconds, then this is probably non-human traffic scraping the site, or performing activities on the site.
      • Reach out to your account manager or support@sharethrough.com in order to review scenarios of illegitimate traffic.
  • SafeFrame Creative in Prebid

    • Symptoms
      • A common scenario is a Publisher which has pushed line items to their Ad Manager and associated creative with SafeFrame enabled.
        In some cases this yields a 100% discrepancy as the contained creative is unable to detect the parent domain correctly.
    • How to Resolve
      • We recommend using non SafeFrames whenever possible, however, ensuring that your Prebid configuration has enabled all relevant SafeFrame requirements is very important.
  • User Drop-Off and Bounce Rates

    • Symptoms
      • Some site layouts may result in users viewing content quickly and then leaving the page, or loading new ads, before the ads have had a chance to complete rendering.
        Even though the ad payload is returned on page it still takes a bit of time for the end-user's browser to read the ad payload, render the payload, and then all the ad assets to be retrieved and rendered to the user.
        There may also be resources on page which are blocking ads from rendering until the page content is loaded, if this is long enough, the user may view the page content and move on before ads are loaded.
        Analytic tools will usually provide user drop-off rates.
    • How to Resolve
      • Load ads in a simple, asynchronous way.
      • Try not to use heavy resources which would take resources away from rendering site content.
      • Look at Analytic reports to identify user patterns and update your site(s) to increase time in page.
      • Make ad slots "sticky" by updating content but leaving the ad window in view and untouched, calling an ad refresh function instead of reloading the entire page.
  • Did you modify the placement tag?

    • Symptoms
      • The placement ID from domainA.com as also used on domainB.com.
      • This may cause issues where too many impressions are logged in the ad server for domainA.com, and no impressions on domainB.com.
    • How to Resolve
      • Make sure the pKeys generated from your Pub Maestro account associated to your domains are only used for the domains intended.
  • Are you tracking impressions based on page views?

    • Symptoms
      • The publisher is reporting using page views from a third party tool instead of the ad server.
        A page may contain multiple ad slots with each ad slot being a request, this usually leads to a large discrepancy between page views and ad requests/impressions.
    • How to Resolve
      • Reporting should be done per placement in both the publisher ad server and the Pub Maestro platform to ensure "apples to apples" comparisons are reviewed.